Upgrading from a previous version of Perception

Applies to the following products: 
Questionmark Perception
Applies to the following Perception versions: 
Perception 5.4

The upgrade process to 5.4 will vary depending on what version of Perception you are currently running and what operating system and database platform it uses.

If you are using the following, please refer to Upgrading from Perception 5.1 or 5.2:

  • Perception 5.1 or 5.2
  • Windows Server 2008
  • SQL Server 2008 or Oracle 11g

If you are not using any of the above, read on.

If you are using a previous version of Perception, you will likely need to upgrade your operating system and/or database technology before attempting to upgrade Perception itself.

Questionmark recommend the following resources:

Upgrade required

Useful resources

Upgrade from Windows Server 2000 or 2003

Upgrades to Windows Server 2008 or R2 (64-bit) from the following operating systems are not supported:

  • Windows XP, Windows Vista, and Windows 7
  • Windows 2000 Server, Windows Server 2003 RTM, Windows Server 2003 with SP1, and Windows Server 2003 Web

Upgrades to Windows Server 2008 (32-bit) from the following operating systems are not supported:

  • Windows XP, Windows Vista, and Windows 7
  • Windows 2000 Server and Windows Server 2003 (64-bit)

If you are using a Windows version that can not be upgraded to Windows Server 2008, please refer to Recommendations for installing from a version of Windows that can't be upgraded.

If Perception is installed on a version of Windows that can be upgraded to Windows Server 2008 or R2 (64-bit), please refer to:

Upgrading to Windows Server 2008

Once you have successfully upgraded you operating system, please refer toRecommendations for installing from a version of Windows that can be upgraded.

Upgrade from Windows XP, Windows Vista, or Windows 7

Upgrade from SQL Server 2005

SQL Server 2008 Upgrade Technical Reference Guide

Upgrading to SQL Server 2008 R2

Upgrade from Oracle 9i or 10g

Upgrading to Oracle 11g and 11g Release 2

If you have any difficulties carrying out these upgrades, please contact the software vendor for assistance.

Recommendations for installing from a version of Windows that can't be upgraded

It is recommended that you follow the procedures highlighted below if your operating system can't be upgraded:

  1. Upgrade your existing database server to SQL Server 2008 or Oracle 11/install a new database server and migrate your content to it
  2. Install a new server with Windows Server 2008 or R2 (32- or 64-bit) and the necessary software prerequisites
  3. Copy the necessary files from your Perception 4 or 5 machine to the new server you set up for Perception 5.4
  4. Run the installer and install Perception 5.4
  5. Set up Perception using the configuration application
  6. Create a new ODBC connection to your upgraded/migrated database
  7. Link your old repository up to the Shared Repository Manager
  8. Run the Upgrade Wizard

For information about how to migrate your content to Perception 5.4 in this type of upgrade, please refer to Upgrade from Perception 4.x.

Recommendations for installing from a version of Windows that can be upgraded

If your operating system can be upgraded, it is recommended that you carry out the following steps:

  1. Upgrade your existing database server to SQL Server 2008 or Oracle 11/install a new database server and migrate your content to it
  2. Run through the operating system upgrade process
  3. Install the necessary software prerequisites
  4. Run the installer and install Perception 5.4
  5. Setup Perception using the configuration application
  6. Run the Upgrade Wizard

For information about carrying out the upgrade procedure for Perception, please refer to Upgrading from Perception 5.x.