System requirements | Perception 5.1/5.2

Applies to the following products: 
Questionmark Perception
Applies to the following Perception versions: 
Perception 5.2
Perception 5.1

Before you install Perception Server, you should ensure that your system meets the minimum requirements. These are listed in the following sections:

Note that you will need administrative permissions for the machine on which you will be installing Perception Server. If you want to deliver large volumes of assessments (where large volumes typically mean 500 or more assessments run per day or 50 or more assessments started at exactly the same time), you may have different system requirements to those listed here. If this is the case, we suggest you refer to the following document:

Scalability in Questionmark Perception 

This guide provides best practices on how to set up and run systems with large volumes, and advice on what sort of hardware and software you need to consider if you are envisaging a large volume of assessments in the future. It is available from the Perception Product Support site.

Disk space needed

Depending on the type of installation you intend to carry out, the server on which you want to install Perception must have the required free disk space as highlighted in the table.

Install type Free disk space required
Single server install 500 MB
Multi-tiered installation Space available on server hosting QPLA - Windows: 100 MB Linux: 50 MB
Space available on server hosting Perception Server - 450 MB

Additional space will be required to store logs and resources that are created or required for the system.

Supported operating systems

The following section provides details about what operating systems can be used to install the various parts of Perception Version 5.

Windows requirements

Perception is compatible with the following 32-bit operating systems:

Perception is compatible with the following 64-bit operating systems:

  • Windows XP
  • Windows Vista
  • Windows 7 *
  • Windows Server 2003 (with Service Pack 2)
  • Windows Server 2008
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2008 R2 *

For further details, please refer to the Installing Perception on a 64-bit Operating System section in theAdvanced configuration options chapter.

* Perception Version 5.2 only

Questionmark recommends that you use Windows Server 2003 or Windows Server 2008 for production use. You should use Windows XP, Vista or 7 for low demand low stakes assessments only.

If you want to create assessments that use non-English characters, you will need to install the correct code page conversion tables. This is to ensure that non-English characters can be displayed by Perception and the database server used. For further information about code page conversion tables, please refer to Configuring code page conversion tables in the chapter Configuring your server.

Linux requirements

The following are the minimum system requirements if you are installing QPLA on a Linux operating system.

Minimum system requirements: Supported Linux distributions are:
  • 512 MB RAM
  • 16 MB Hard Drive Space
  • Network/Internet access to the Perception Server
  • Ubuntu Server 8 or 9
  • RedHat Enterprise Linux 5
  • SUSE Linux Enterprise 11

QPLA can be installed on other Linux distributions. However, only the distributions listed above will be supported by Questionmark Technical Services.

Additional components required Description
Apache Apache is the Web Server application that runs on a Unix/Linux environment and is available as Apache 1.x and 2.x. It is recommended that you use Apache 2.0 with QPLA.
PHP

PHP is a scripting language that is used to create dynamic web pages. Perception Version 5 requires PHP 5.2.5 or later to be installed. You must also ensure you have installed the following extensions for PHP:

  • XSL
  • CURL
  • SOAP
  • OpenSSL (if you intend to use SSL)
Samba client

A Samba client is required to allow Linux to mount a Windows based shared folder. Once the shared folder is mounted Linux will be able to read and write files to it as if it was a local folder.

There are many Linux distributions most are grouped in to two types "Server" and "Desktop". While Perception can be installed on Desktop distributions such as Fedora this is only recommended for tryout purposes. For a production installation of QPLA it is recommended that you use a Server edition distribution, preferably one of the ones recommended above.

For further information, please refer to the Linux section of this guide.

Supported databases

The following databases and versions can be used with Perception Server.

Database Versions Notes
SQL Server 2005 and 2008 (32-bit or 64-bit versions) and 2008 R2

In SQL Server there are two database collations to set, the SQL Server collation and the Database collation.

For English and non-English characters to appear correctly when using SQL Server, your collations should be set as:

  • SQL Server collation. This must be configured to use the collation SQL_Latin1_General_Cp1_CI_AS, this collation  utilizes the code page 1252 (ANSI - Latin 1). The collation SQL_Latin1_General_Cp1_CI_AS is the case insensitive version. You should take care not to use the case sensitive version of the collation. The case sensitive version can be identified with the initials CS appearing in the collation title while the case insensitive version can be identified by the initials CI.

    This must be applied to the instance of SQL Server when installing SQL Server. Please be aware that when installing SQL Server 2005/2008 it will automatically attempt to get the most appropriate collation depending on what the server locale has been set as. In most cases this will need to be manually changed to use the SQL_Latin1_General_Cp1_CI_AS.

  • Database collation.This must be set as SQL_Latin1_General_Cp1_CI_AS to ensure that all data written in Perception is stored and displayed correctly. See the section Database setup for instructions how to do this when installing Perception.

Please note that the collation used should be SQL_Latin1_General_Cp1_CI_AS not Latin1_General_CI_AS.

Users wishing to set up an English language version of Perception on a Non-English operating system and database should ensure that the correct  language packs are installed for both the database and the operating system. Additionally, the language pack 1252 (ANSI - Latin 1) must be installed for both servers and the SQL Server collation and database collation set toSQL_Latin1_General_Cp1_CI_AS.

The question searching facility in Authoring Manager requires the Full Text indexing component of SQL Server to be installed and configured and will not work without it. Once Full Text indexing is installed, it will need to be enabled for the database before the repository is created.

Oracle 9i Release 2, 10g and 11g (Windows/Linux 32-bit or 64-bit versions)

There are a number of factors that need to be taken in to account if using Oracle as your database server for Perception. These include:

  • For non-English characters (Latin characters and other Western European characters) to appear properly when using Oracle, your Oracle installation must be configured to utilize the AL32UTF8 character set.
  • For 2-bit characters (such as Japanese, or Chinese) you must utilize the WE8MSWIN125database character set
  • If using the WE8MSWIN1252 database character set on a non-English operating system the National Character Set (NLS) must be set to English (either US or UK)

No other character sets can be reliably supported at this time. You can either change your database to use the appropriate character set (providing that other applications using Oracle can work with this), or else set up a separate Oracle installation with the appropriate character set for Perception to use.

To use the Scoring Tool component of Perception Server with Oracle, ODP.NET (Oracle Data Provider) version 9.2 or higher must be installed on each application server you will be running Perception Server on. ODP.NET can be obtained from the Oracle Web site:

www.oracle.com

The question searching facility in Authoring Manager requires Oracle Text to be installed and configured and will not work without it. Oracle Text is not installed by default in some versions, and may need to be installed.

If you are using Windows Server 2003/2008 64-bit or Windows Server 2008 R2, you will need to use a compatible 32-bit Oracle client on your Perception Server (for example, Oracle 11g 32-bit client) to connect to your Oracle database.
SQL Server Express Microsoft SQL Server 2005/2008 Express Edition

SQL Server 2005/2008 Express is a free desktop database that is limited in functionality when compared to SQL Server 2005/2008. For serious production use, you should not use an SQL Server Express database. However, for running a light production system needing to deliver approximately 1000 assessments per week it is adequate. Questionmark recommends that you use SQL Server 2005/2008 Express Edition with Advanced Services.

SQL Server Express is available to download from the Microsoft web site. For further information and links, please refer to:

SQL Server Express database

If you will be using Perception Server for production use, Perception Server should be installed on an application server (or multiple) and the Perception database (referred to as a repository) should be installed on a separate database server.

Supported browsers

For further information about the supported web browsers for Enterprise Manager, please refer to the following Knowledge Base articles.

Software requirements

The applications required by Perception Server are listed in the following table.

Depending on the operating system you are using and the type of installation you have, these applications may already be installed. Before you install Perception Server, however, you should ensure that they are all present.

Application Notes
PHP

The version of PHP required is PHP 5.2.5 or higher. Using a previous version of PHP is not recommended and is unlikely to work as expected. PHP is required to allow the Presentation tier to function. The Presentation tier is the part of the application that renders questions and assessments in a usable form through a participant's web browser. PHP will need to be installed:

  • On the same server as Enterprise Manager if you are using a single server
  • On the server dedicated to the Presentation tier in a multi-tiered setup

In addition, the PHP installation also requires the following extensions to ensure Perception will work properly:

  • CURL
  • SOAP
  • XSL
  • OpenSSL (if planning to run Perception using SSL via HTTPS)

To find out more about installing PHP, please refer to:

Installing PHP

SMTP

Perception can be configured to send emails to participants at the end of assessments, or with Email Broadcast. If you do not want to configure Perception to send emails, however, this is not required.

It is possible to configure Perception to send emails using a local SMTP service in IIS or connect to an external SMTP service (For example, one that is provided by your Internet Service Provider.).

In Windows Server 2003, Windows Server 2008, Windows Vista and Windows XP, SMTP is part of IIS (Internet Information Services) but needs to be installed. To find out more about installing and configuring SMTP, please refer to the section:

Configuring your server

However, the SMTP service doesn't have to be supplied by Microsoft. Please refer to Configuring E-Mail services for further details on how to specify the address and port settings that Perception will use.

.NET

Perception Version 5 requires the .NET 2.0 Framework to be installed on the application server. Provided you have .NET 2.0 Framework installed, you can also have .NET Framework version 1.1 and the .NET 3.0/3.5 Framework installed on the same server.

If you are using Windows Server 2003 R2 or Windows Server 2008 the .NET 2.0 Framework is installed by default. However, If you run the installer without first installing the .NET 2.0 Framework on Windows XP or Windows Server 2003 a choice will be offered to the user to download and install the .NET 2.0 Framework components. This download facility requires an Internet connection.

You can check what versions of the .NET Framework are installed by checking in the following folder on your server:

C:\Windows\Microsoft.NET\Framework

Each installed version of the .NET Framework will have a corresponding folder.

IIS

IIS is not installed by default. To find out if you have IIS installed, click Start, click Control Panel, and then double-click Administrative Tools. ClickInternet Information Services (IIS) Manager. If you cannot see IIS Manager listed, then you do not have it installed.

For further information about how to install IIS, please refer to the following section for your specific operating system:

Configuring your server

License files

When you install Perception Server, a license is included that allows you to use the product for 14 days. After this evaluation period expires, you will need to obtain a valid license. Please refer to Licensing Perception for more information once you have installed Perception Server.

Virtual environments

Perception can be installed and run in virtual environments. Questionmark supports installations of Perception in the following virtual environment platforms:

  • VMWare

    VMWare is a virtualization solution produced by VMWare Inc. and is the market leader in virtualization. VMware software provides a completely virtualized set of hardware to the guest operating system.

  • Hyper-V

    Hyper-V is a hypervisor based virtualization system for x64 bit systems. It is a new virtualization technology that Microsoft implemented in Windows Server 2008 and directly replaces Microsoft Virtual Server. Hyper-V is built in to the host and guest operating systems and allows for improved performance over Microsoft's traditional virtualization methods.

If using virtual environments care should be taken to ensure that the host computer running the virtualization software is robust and powerful to ensure that Perception is not left without the ability to create and store data or process actions. The virtual environments need to be setup to work as hardware based machines and should be setup with adequate amounts of memory, hard drive space and processor speed. The network configuration for the virtual environment will depend on your organization network setup, but Perception has been tested extensively using a bridged network connection from the virtual environment to the physical network.

Questionmark Perception is multi-threaded, but it is not specifically vSMP aware. It will use whatever resources the guest operating system makes available to it. While it can be run on guest operating systems that utilize a single vCPU or multiple vCPUs, it is unable to communicate directly with the host operating system in a virtualized environment to optimize resources via vSMP.

The workload of delivering assessments from Perception is handled by IIS. IIS assigns a response to a thread and thus the processor use is determined by IIS and not by Perception.

General virtualization tips include:

  • Don't mix single vCPU and multiple vCPU guests on a single host.
  • Prevent the straddling of CPUs (for example, a server with 2x 6-core CPUs cannot run 3x 4-vCPU guests efficiently as one would straddle two CPUs)
  • Ensure host capacity is capable of supporting all guest operating systems under load. If the host constantly runs at close to 100% consider separating some of the guest systems to other hosts.