Installing PHP

Applies to the following products: 
Questionmark Perception
Applies to the following Perception versions: 
Perception 5.2
Perception 5.1

Perception 5 requires PHP to be installed and configured before you will be able to deliver assessments to participants via the Questionmark Presentation Layer for Assessments (QPLA). QPLA requires PHP version 5.2.5 or higher to be installed and configured before it will function correctly. However, if you are installing in a multi-tiered environment you will only need to install PHP on the server you intend to use as the Presentation tier (where QPLA will be installed). For further information about the possible arrangement of Perception 5, please refer to Types of installations. It is recommended if you are installing PHP on a Windows environment that you configure PHP to use FastCGI.

For instructions on installing and configuring PHP for Perception 5.1/5.2, please refer to the following Knowledge Base articles:

If you are installing QPLA on Linux, please refer to Configuring Linux for QPLA for instructions about how to install PHP on Linux.