5. Install the prerequisites on your ETL server | Questionmark

5. Install the prerequisites on your ETL server

Applies to the following products: 
Questionmark Perception
Applies to the following Perception versions: 
Perception 5.7

The following applications need to be installed on your ETL server.

These programs must be installed and configured before you install the ETL service. Click on the individual program to see instructions and notes on its installation and configuration.

Details for configuring SQL Server can be found on the following page, step 6 (Install a database system to handle the ETL_Temp database).

Required applications

  • Microsoft .NET Framework 4.0

    You can download .NET 4.0 from:

    Microsoft .NET Framework 4.0

    Once downloaded, double-click on the installer and follow the instructions to install .NET 4.

Internet Information Services (IIS) 7.5

You will need to ensure that you have administrative user rights on the server on which you plan to install IIS.

To install IIS:

  1. Click Start | All Programs | Administrative Tools | Server Manager
  2. In the Server Manager window, scroll down to Roles Summary, and then click Add Roles. The Add Roles Wizard will start with a Before You Begin page. The wizard asks for verification of the following:
    • The administrator account has a strong password
    • The network settings, such as IP addresses, are configured
    • The latest security updates from Windows Update are installed
  3. Select Web Server (IIS) on the Select Server Roles page. An introductory page will open with links for further information.
  4. Select the IIS services to be installed on the Select Role Services page. Add the following modules, and click Next:
    • Static Content
    • Default Document
    • ASP
    • ASP.NET
    • .NET Extensibility
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
    • Windows Authentication
    • IP and Domain Restrictions
    • IIS Management Console
    • IIS Management Scripts and Tools
    • IIS 6 Management Components (or the whole IIS 6 Management Compatibility subtree)
  5. Click Add Required Role Services
  6. Wait for IIS to complete installing, and click Finish
  7. Locate the Features Summary, and click Add Features
  8. Enable the following Features:
    • .NET Framework 3.0 (inside the .NET Framework 3.0 Features category)
    • HTTP Activation (inside the WCF Activation category)
  9. Click Next, followed by Install
  10. Once the features have been installed, click Close and exit Server Manager

Once IIS is enabled, make sure the ASP.NET State Service is running. To do this:

  1. Click Start | Administration Tools | Services
  2. Locate and right click on the ASP State Service entry
  3. Click Properties
  4. Make sure the Startup type is set to Automatic
  5. Click Start to start the service now
  6. Click OK and exit out of the Services window

Running 32-bit applications in 64-bit IIS

If you are planning to run 32-bit applications (i.e., Perception) in a 64-bit version of IIS, you will need to ensure that the correct settings are enabled. The settings are enabled by running specific commands and parameters from the command line. You will need to launch the command line prompt as an administrative user (you can do this by logging in as an administrative user or by right-clicking on the command prompt icon and clicking Run as administrator).

To enable 32-bit applications to run in 64-bit IIS, enter the following command at the prompt:

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

To enable the 32-bit version of the .NET 2.0 Framework for use with Perception, you will need to run the following command:

%SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

...or, if that is unavailable, try:

%SYSTEMROOT%\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

  • SQL Server 2008 R2